Browser requirements (get the latest version)

When using Rentman, always make sure that you're using the latest version of your webbrowser. This is important, because older versions of your browser are always at increased risk of causing issues with our software.

-

Latest browser version

Warning: Internet explorer is an outdated webbrowser, and is not actively supported anymore. We do not recommend using this.

Rentman App (iOS & Android)

The operating system of your smartphone must be:

  • Android 4.4, or later
  • iOS 9, or later

Read our article about the Rentman App for more information.

How do I connect to Rentman?

Connect to Rentman at https://accountname.rentmanapp.com/.

To find the account name of your company, read this article

Having connection problems?

The following can cause connection problems with Rentman:

  • Anti-virus software
  • Adblockers
  • Disabled Javascript
  • VPN's
  • Proxy connections

Please read our article about Websocket connections to learn how to prevent and solve these.

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.