Problemen met de webshop oplossen

Webshops bestaan uit veel losse onderdelen, waarvan onze Wordpress verhuurshop plugin er één is. Wanneer je webshop niet werkt, ligt de oorzaak bij één van de losse onderdelen. Dit kan veroorzaakt worden door de Wordpress verhuurshop plugin, maar ook door een ander onderdeel van je webshop. Het is ook mogelijk dat de plugin niet compatibel is met een ander onderdeel van je webshop.

Omdat jouw webshop draait in je eigen omgeving met je eigen instellingen, kunnen wij het probleem niet direct voor jou achterhalen. Je zal zelf op zoek moeten gaan naar het probleem, en een oplossing daarvoor bedenken. Dit artikel biedt enkele aanknopingspunten.

Als je tegen een (over)duidelijk probleem aanloopt in de plugin die makkelijk reproduceerbaar is, neem dan contact op met onze partner AppSys. Zij ontwikkelen en beheren de Wordpress verhuurshop plugin, en kunnen helpen om dit probleem op te lossen.

Mogelijke problemen

Thema

Zoals met elke Wordpress/WooCommerce shop wordt het uiterlijk voor het grootste deel bepaald door het thema dat geïnstalleerd wordt. Het is mogelijk dat het thema functionaliteiten heeft die niet samenwerken met functionaliteiten uit de Rentman plugin.

Voorbeeld: Vanuit een thema kunnen instellingen toegevoegd worden voor een enkele leverdatum. Dit kan een conflict opleveren met de van- en totdatum die vanuit de Rentman plugin toegevoegd worden. In dit geval ontstaat er een error door de instellingen in het thema.

(Automatische) updates van andere onderdelen

Het kan zijn dat er spontaan iets misgaat in je webshop, terwijl je niets hebt aangepast of veranderd.

Het kan zijn dat sommige onderdelen van je webshop (automatisch) updates ontvangen, waardoor er fouten optreden die er in eerste instantie niet waren. Denk hierbij aan updates van Wordpress, WooCommerce, of je hosting omgeving. In dit geval zal je zelf moeten onderzoeken of en waar er een probleem is ontstaan na updates van één of meerdere onderdelen. Vanuit Rentman kunnen wij hier geen support voor bieden, aangezien je webshop op je eigen omgeving draait.

De plugin kan niet overweg met een ander onderdeel

Het kan zijn dat je webshop correct functioneert wanneer je de Wordpress verhuurshop plugin uitschakelt, maar dat er iets misgaat zodra je hem weer inschakelt.

Sommige onderdelen van je webshop kunnen mogelijk niet met elkaar overweg. Ze zijn dan niet compatibel met elkaar.

Veelvoorkomende complicatie: Het thema dat je installeert bevat bepaalde functionaliteiten die niet samen kunnen werken met de Wordpress verhuurshop plugin. Er zijn vele duizenden verschillende thema's, en het kan zijn dat gedeelte hiervan dusdanig aangepast is dat onze plugin hier niet op voorbereid kan zijn.

Mogelijke oplossingen

Gebruik altijd de nieuwste versie van je onderdelen

Het is belangrijk dat je altijd de nieuwste versie van verschillende onderdelen in je webshop draait. Om te dit te controleren, kun je het volgende doen:

  1. Vraag een WooCommerce system status report op.
    Ga naar de Adminomgeving van WordPress > WooCommerce > System Status

Wanneer je dit rapport opvraagt, moeten de volgende onderdelen de volgende versie hebben:

  • PHP (versie hoger dan 5.6)
  • WooCommerce (nieuwste versie)
  • Wordpress (nieuwste versie)
  • Onze Wordpress verhuurshop plugin (nieuwste versie)

Als één van deze onderdelen niet is geüpdate naar de benodigde versie, zorg dan dat deze geupdate worden.

Mijn probleem is niet opgelost

Als je na het lezen van de aanknopingspunten in dit artikel niet verder bent gekomen, kan je contact opnemen met onze partner AppSys. Zij ontwikkelen en beheren de Wordpress verhuurshop plugin, en kunnen helpen om je probleem te traceren en een oplossing te vinden.

Was dit artikel nuttig?
Aantal gebruikers dat dit nuttig vond: 0 van 0

Opmerkingen

0 opmerkingen

U moet u aanmelden om een opmerking te plaatsen.