Integrating your Rentman account with QuickBooks Online is essential for maintaining accurate and up-to-date financial records. However, you may encounter error messages that can be difficult to interpret. In this article, we will break down the most common errors and guide you through resolving them.
Take a look at this article on how to connect Rentman to Quickbooks first!
Why are my invoices not exporting & Where can I check this?
To see the reason why your invoices are failing to export to Quickbooks Online, you will need to add two columns : Export Remark and Export Status.
- Select the monetization_on Financial Module, go to Invoices
- Add the column of Export Remarks and Export status
- An alternative way is to select the details button of an invoice and scroll down to Export Information
Export Status | Status of the invoice being exported to Quickbooks. Current statuses include: Not yet exported, Successfully Exported and Failed are the options |
Export Remark | This column displays the error message explaining why your invoice was unsuccessful when exporting |
Only after you export your invoice successfully or unsuccessfully will there be data in these two columns. Create a test export project to keep things separate!
Potential error messages and their fixes
After adding the Export Remark column, you are now able to see the main blocker that is preventing the export. Here are the most common error messages customers encounter:
Root cause: |
The project's tax rate connected to this invoice does not match or is missing the tax rate connected to Quickbooks. |
Solution: |
Check the tax connection between Rentman and Quickbooks in settings Configuration, go to Extensions and scroll down to select Tax/VAT Rates. Make sure the tax percentages match for both RM and QB fields, this ensure accurate tax calculations are being exported. Regenerate your invoice after making any changes and try exporting again. |
Root cause: |
In the invoice you are trying to export, a Rentman ledger item line does not match or is missing the Quickbook ledger (Products and Services). This item can be an equipment, crew function or an additional cost. Anything that is charged to a customer has a ledger. |
Solution: |
Check your ledger connections in settings Configuration, go to Extensions and scroll down to select Ledgers. Ensure that you have the RM ledgers matched correctly with the QB ledgers of your choice. |
Tip: |
Add the column of ledger in your project tabs to see every item line's ledger at once. |
Root cause: |
When exporting this invoice, the invoice number in Rentman is already being used in Quickbooks. You can not have duplicated invoice number in QB. |
Solution: |
Either edit the invoice number in RM or in QB. Regenerate and try exporting again. If you want to remove the duplicated invoice in QB, see the tip provided below on how you can locate the specific invoice. |
Tip: |
In the error, the "DocNumber = XXX" refers to the invoice number in QB that is blocking you from exporting. Find the duplicated invoice in QB and remove it. "TxnId=XXX" will also identify the specific invoice. Look at your browsers URL while viewing an invoice in QB. |
Root cause: |
The invoice's project does not have a customer attached. |
Solution: |
In the invoice's project, add a customer from your contact database. Regenerate your invoice after any changes and try exporting again. |
After fixing your issue or making any changes, regenerate your invoice so it has the most up to date data. If you do not, the document may still be holding onto old data preventing you from exporting.