Integrating your Rentman account with XERO is essential for maintaining accurate and up-to-date financial records. However, you may encounter error messages that can be difficult to interpret. In this article, we’ll break down the most common errors and guide you through resolving them.
Take a look at this article on how to connect Rentman to XERO first!
Why Won't My Invoices Export?
To see the reason why your invoices are failing to export to XERO, you will need to add two columns : Export Remark and Export Status.
- Select the monetization_on Financial Module, go to Invoices
- Add the column of Export Remarks and Export status
- An alternative way is to select the details button of an invoice and scroll down to Export Information
Export Status | Status of the invoice being exported to XERO. Current statuses include: Not yet exported, Successfully Exported and Failed are the options |
Export Remark | This column displays the error message explaining why your invoice was unsuccessful when exporting |
Only after you export your invoice successfully or unsuccessfully will there be data in these two columns. Create a test export project to keep things separate!
Potential error messages and their fixes
After adding the Export Remark column, you are now able to see the main blocker that is preventing the export. Here are the most common error messages customers encounter:
Root Cause: | In the invoice you are trying to export, a Rentman ledger item line does not matching or is missing the XERO ledger (Charts of Account). This item can be an equipment, crew function or an additional cost. Anything that is charged to a customer has a ledger. |
Solution: | Check your ledger connections in settings Configuration, go to Extensions and scroll down to select Ledgers. Ensure that you have RM ledgers matched correctly with the XERO ledgers of your choice. Look through the invoice's project with items that contain the ledger of ABC. Ensure that all items in the project has a RM ledger connected to a XERO ledger. Regenerate your invoice after any changes and try exporting again |
Tip: | In the error message, ABC represents the ledger name that is blocking. The # refers to the ledger ID. |
Root cause: | In the invoice you are trying to export, a XERO ledger you used is not valid to the document type. |
Solution: |
In settings Configuration > extensions > ledgers, find the ledger that is producing the error and replace it with another valid ledger. |
Tip: |
To find the correct XERO ledger that is causing you issue, access your XERO account and go to Chart of Accounts. From there, find code XXX using the code column and identify the ledger name. |
Root cause: |
Your XERO account does not have the correct currency included in its settings. |
Solution: |
In XERO, select your organization top left of the page settings > currencies > add currency. Try exporting again! |
After fixing your issue or making any changes, regenerate your invoice so it has the most up to date data. If you do not, the document may still be holding onto old data preventing you from exporting.